Back to overview
Degraded

⚠️ Degraded performance in Asia and Australia.

Dec 24 at 09:24am IST
Affected services
tlchmedia.com

Resolved
Dec 29 at 09:20am IST

✅ We have implemented a fix and are closely monitoring response times.
If you are still experiencing issues, please use the "Get in touch" button at status.tlchmedia.com.

Updated
Dec 27 at 09:28pm IST

🛠 We have identified the cause of the issue and are working on a proper solution.
Performance should improve in affected regions within the next few hours.

Updated
Dec 26 at 03:03pm IST

We've contacted our website host and we're looking into possible solutions.
We will keep updating as we figure out the source of the issue.

Created
Dec 24 at 09:24am IST

Regions such as Asia and Australia may be experiencing slower loading times. We are currently working on a solution.